Как xml с подписью загрузить в 1с
Перейти к содержимому

Как xml с подписью загрузить в 1с

  • автор:

Новый сервис ФНС — визуализация XML-документов

Ожидается также поддержка других форматов электронных документов после их утверждения.

Пользователи 1С-ЭДО могут опробовать сервис ФНС — для этого нужно в «Архиве ЭДО» осуществить выгрузку документов с выбором варианта «Для предоставления в ФНС». В выгруженном архиве будет доступен XML-документ и файлы с подписями в формате sgn, которые можно загрузить в сервис ФНС.

Выгрузка электронных документов из 1С.png

Таким образом, любой участник ЭДО при предоставлении третьему лицу на проверку или в качестве подтверждения документов в электронном виде, может не просто переслать электронный документ, но и указать способ его проверки на официальном сайте ФНС в случае, если у получателя нет собственного ПО для визуализации XML-документа и проверки электронной подписи.

Как xml с подписью загрузить в 1с

Переходим в раздел Отчеты — 1С-Отчетность — Регламентированные отчеты

Переходим на верхней панели в раздел Настройки

Переходим в раздел Отчеты в Росстат — Настройка XML-шаблонов электронных версий отчетов

Переходим на сайта Росстата по ссылке выделенной синим цветом

Откроется интернет браузер с XML-шаблонами

Выбрать нужный шаблон

Нажать ссылку Скачать

Загруженный файл необходимо распаковать с помощью архиватора, нужный нам файл имеет расширение xml

Далее в программе 1С нажимаем кнопку Загрузить

В отрывшемся окне выбираем нужный нам файл (шаблон) из того места, куда был распакован (разархивирован) загруженный архив с шаблоном

В списке шаблонов должен появится необходимый Вам шаблон

Для того, чтобы создать новый отчет в Росстат из данного шаблона необходимо перейти в создание нового отчета

В группе отчетов СтатистикаПрочие формы, выбрать нужный шаблон

Либо перейти в списке Статистика:Прочие формы

И при создании нового отчета выбрать форму

загрузка документов из xml в 1с

при написании обработки загрузка документа «ЗаказПокупателя» из xml-файл столкнулся с такой проблемой:
в xml-файл записано n-кол-во документов, клиент заказывает несколько позиции товара, как сделать чтобы товар одного клиента попадал в один документ, и как выполнить проверку на дубликаты документов при загрузке xml-файла.

По теме из базы знаний

  • Загрузка документов и номенклатуры из Excel в 1С «одним нажатием»: УПД, ТОРГ-12, отчеты маркетплейсов, заказы, счета, прайсы
  • Загрузка документов из М-Аптеки для БП 2.0
  • Загрузка документов поступления в 1С из XML формата 820 (Контур.Диадок) для УТ10, УТ11, Бух3, КА2, КА2.5, УПП1.3 и обработка выгрузки УПД в Контур Диадок и СБИС для 1С:Бухгалтерии 3
  • Групповая выгрузка и загрузка файлов XML для ЭДО в каталог по приказу №820 ФНС (для УТ 10.3/11, КА2, ERP2, БП3, УНФ, УПП1.3, Розница2.3). Поддержка маркировки. Прослеживание товаров.
  • Массовая загрузка документов с ЭДО в 1С:БП3
  • Дата
  • Дата
  • Рейтинг всех уровней
  • Рейтинг 1-го уровня
  • Древо развёрнутое
  • Древо свернутое

Свернуть все
2. andrewks 1367 28.09.12 14:41 Сейчас в теме
честно говоря, при такой постановке вопроса даже посоветовать что-то сложно. слишком мало информации
3. Aleksey58 30.09.12 16:11 Сейчас в теме

Вот моя обработка,

//XML ЧтениеXML = Новый ЧтениеXML; ЧтениеXML.ОткрытьФайл("positions.xml"); Имя = ЧтениеXML.Имя; Массив = Новый Структура(Имя); Пока ЧтениеXML.Прочитать() Цикл ПолучитьXMLТип(ЧтениеXML); Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда Имя = ЧтениеXML.Имя; Пока ЧтениеXML.ПрочитатьАтрибут() Цикл Атрибут = ЧтениеXML.Значение; КонецЦикла; КонецЕсли; Если ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда Массив.Вставить(Имя, ЧтениеXML.Значение); КонецЕсли; Если ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента И ЧтениеXML.Имя = "pst_article_display" Тогда Если Массив.pst_ord_id <> "заказ" Тогда ДокПозицииЗаказКл = Документы.ЗаказПокупателя.СоздатьДокумент(); ДокПозицииЗаказКл.Заказ = Массив.pst_ord_id; ДокПозицииЗаказКл.Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(Массив.customer); ЧислоДаты = Лев(Массив.pst_arrival_date,2); МесяцДаты = Сред(Массив.pst_arrival_date,4,2); ГодДаты = Прав(Массив.pst_arrival_date,2); ПравильнаяДата = "20" + ГодДаты + МесяцДаты + ЧислоДаты; ДокПозицииЗаказКл.Ожидается = Дата(ПравильнаяДата); ДокПозицииЗаказКл.Баланс = Массив.cst_balance; ДокПозицииЗаказКл.Срок = Массив.pst_term; ДокПозицииЗаказКл.ГарСрок = Массив.pst_max_term; ДокПозицииЗаказКл.Направление = Массив.pst_destination; ДокПозицииЗаказКл.Комментарий = Массив.pst_comment; Если Массив.pst_manager_comment <> "коммент. менеджера" Тогда ДокПозицииЗаказКл.КомментМенеджера = Массив.pst_manager_comment; КонецЕсли; ТоварКл = ДокПозицииЗаказКл.Товары.Добавить(); ТоварКл.Артикул = Массив.pst_article; ТоварКл.Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию(Массив.pst_name); ТоварКл.Производитель = Массив.pst_brand; ТоварКл.Количество = Массив.pst_amount; ТоварКл.Цена = Массив.pst_price; ТоварКл.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС; ТоварКл.Сумма = Массив.summ; ТоварКл.Оплачено = Массив.payed; ТоварКл.Долг = Массив.debt; ФормадокументаЗаказКл = ДокПозицииЗаказКл.ПолучитьФорму(); //ФормадокументаЗаказКл.Записать(); ФормадокументаЗаказКл.Открыть(); КонецЕсли; КонецЕсли; КонецЦикла;

Как сделать чтобы номенклатура клиента записывалась в один документ, а не создавался новый документ, и проверку на дубликат документа

Новый сервис ФНС «Визуализация XML-документов» уже в 1С-ЭДО

На сайте ФНС России появилась возможность визуализировать электронные документы формата XML в формат PDF. Как сообщается на странице сервиса , пользователи могут проводить визуальный анализ, а также предоставлять человекочитаемые формы документов по месту требования.

Сервис позволяет визуализировать одновременно несколько титулов одного документа и отображать штампы открепленных электронных подписей (потребуется дополнительно загрузить файлы подписи в одном из форматов: sign, sig, sgn). Также на визуализированном документе проставляется отметка с указанием даты и времени визуализации.

В сервисе поддерживается визуализация форматов, утвержденных следующими приказами ФНС:

  • Приказ ФНС России от 30.11.2015 № ММВ-7-10/551@ «Об утверждении формата представления документа о передаче товаров при торговых операциях в электронной форме»;
  • Приказ ФНС России от 30.11.2015 № ММВ-7-10/552@ «Об утверждении формата представления документа о передаче результатов работ (документа об оказании услуг) в электронной форме»;
  • Приказ ФНС России от 13.04.2016 № ММВ-7-15/189@ «Об утверждении формата корректировочного счета-фактуры и формата представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме»;
  • Приказ ФНС России от 19.01.2018 № ММВ-7-15/820@ «Об утверждении формата счета-фактуры, формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг) в электронной форме»;
  • Приказ ФНС России от 27.08.2019 № ММВ-7-15/423@ «Об утверждении формата представления документа о приемке материальных ценностей и (или) расхождениях, выявленных при их приемке, в электронной форме»;
  • Приказ ФНС России от 12.10.2020 № ЕД-7-26/736@ об утверждении формата корректировочного счета-фактуры, формата представления документа, подтверждающего согласие (факт уведомления) покупателя на изменение стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, и формата представления документа, подтверждающего согласие (факт уведомления) покупателя на изменение стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, в электронной форме.

Ожидается также поддержка других форматов электронных документов после их утверждения.

Пользователи 1С-ЭДО могут попробовать сервис ФНС – для этого нужно в «Архиве ЭДО» осуществить выгрузку документов с выбором варианта «Для предоставления в ФНС». В выгруженном архиве будет доступен XML-документ и файлы с подписями в формате sgn, которые можно загрузить в сервис ФНС.

Таким образом, любой участник ЭДО при предоставлении третьему лицу на проверку или в качестве подтверждения документов в электронном виде, может не просто переслать электронный документ, но и указать способ его проверки на официальном сайте ФНС в случае, если у получателя нет собственного ПО для визуализации XML-документа и проверки электронной подписи.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *